Welcome to the Rocks and Ruts Off-Road Powersports Community

Wanting to join the rest of our members? Feel free to sign up today.

Sign Up
  1. Welcome Guest to the Rocks and Ruts Off-Road Powersports Community Forums. Be sure to register. It's quick and 100% free.
  1. blackbirdxp1k

    blackbirdxp1k Site Supporter

    Joined:
    May 8, 2012
    Messages:
    1,360
    Likes Received:
    444
    Location:
    Langlade County, Wisconsin
    Haven't even been on here as much. One thing I'm updating on about my rzr is I might be having to get new winch as I'm having issues with support from motoalliance for my viper winch. I was out riding at night in heavy storm when I noticed low voltage light come on. Just for few seconds. I than heard a loud bang and something flew up. Just thought might hit something, but was raining so hard I wanted just check out in the morning when wasn't raining hopefully. Well next day I found out my winch had pulled in until the solid aluminum fairing busted. Than pulled in till bent the bolt on the winch. I don't know if the winch burnt up or in reaction to the low voltage I flip a few of the switches including the winch one and stopped it. I looked at the switch the next day and when I removed my dash it fell apart and the contactor piece metal was not in right position. This was all way back in may memorial weekend. I contacted motoalliance and they said to send it all in so they could look it over but electrical issues aren't covered normally after a year. Said they see if they could do anything for me. Well I didn't here anything from them, and in end June I emailed them for update and they told me they hadn't received my winch. I replied with email where I sent it to for address and when I sent it out. Since then I've now gotten no answers, and I've even sent another email asking for answers. I'm gonna send another today, but now I'm worried my winch is just gone. I wanted to wait see what happens before made any post on this but think waited long enough. I'm really upset now. I had winch take crap cause faulty switch, send it it in to have it disappear, than get no answers after one email about them not seeing it, and now I have no winch to even try to rebuild at least! It aggravating. I'll add pics later as at my house it takes to long with reception I have.
     
    #1
  2. blackbirdxp1k

    blackbirdxp1k Site Supporter

    Joined:
    May 8, 2012
    Messages:
    1,360
    Likes Received:
    444
    Location:
    Langlade County, Wisconsin
    Thing is I've never used this winch even.
    [​IMG]

    [​IMG]


    [​IMG]
     
    #2
    Last edited: Aug 20, 2016
  3. bluesmanjesse

    bluesmanjesse Moderator
    Staff Member

    Joined:
    May 8, 2012
    Messages:
    3,672
    Likes Received:
    1,299
    Location:
    Eaton Ohio
    I've had good service out of my Superwinch Terra 45
     
    #3
  4. blackbirdxp1k

    blackbirdxp1k Site Supporter

    Joined:
    May 8, 2012
    Messages:
    1,360
    Likes Received:
    444
    Location:
    Langlade County, Wisconsin
    Well looks like they are sending me brand new winch. Sounds like they don't know where my winch ended up that I shipped to them. Apologized for dropping ball on it. Gotta call them tomorrow, but said they have winch sent out today.
     
    #4
  5. Hammer

    Hammer Moderator
    Staff Member

    Joined:
    May 7, 2012
    Messages:
    2,524
    Likes Received:
    1,478
    Location:
    Western Pennsylvania
    Sounds like they're trying to make it right
     
    #5
    liquid1 likes this.
  6. blackbirdxp1k

    blackbirdxp1k Site Supporter

    Joined:
    May 8, 2012
    Messages:
    1,360
    Likes Received:
    444
    Location:
    Langlade County, Wisconsin
    Yep, think it helps when you mention a forum posting also. Got reply faster for sure. Just wonder where my original winch is really at this point. If everything goes well I'll prolly take this post down cause they fixed this right.
     
    #6
    KEETER likes this.
  7. blackbirdxp1k

    blackbirdxp1k Site Supporter

    Joined:
    May 8, 2012
    Messages:
    1,360
    Likes Received:
    444
    Location:
    Langlade County, Wisconsin
    Got brand new winch in the mail today. That was quick. Been so busy with work wasn't able call back
     
    #7
    Hammer and NCMudman like this.
  8. NCMudman

    NCMudman Member

    Joined:
    May 14, 2012
    Messages:
    1,570
    Likes Received:
    1,060
    Location:
    Murphy NC
    Good luck with the new winch Scott!
     
    #8
    blackbirdxp1k likes this.
  9. KEETER

    KEETER Member

    Joined:
    May 9, 2012
    Messages:
    598
    Likes Received:
    334
    Scott I don't know if I would take it down as yes there was a problem that might help somebody later on with similar problem. But by all means Let's make sure that Mot Alliance get the credit due to them and for the speedy replacement. If you talk to them and tell them your happy and why you might leave it up I'm sure they might be fine with it. I ran their Elite on my Grizz700 with remote for years and it was still working when the 700 got stolen. I had a similar experience with the winch coming on while riding and found out the remote was working it everytime something would hit the keypad on my spare remote in the storage box. LOL only way I found it was I was looking for something and it starting working everytime I moved something in the glovebox.
     
    #9
Loading...

Share This Page